PowerMTA Support Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

PowerMTA 5.0r7 is out!!!!  Please contact support@port25.com for a license and download access.

Author Topic: SMTP email not sending with secondary server ip address using virtual Mta  (Read 1156 times)

sysnxweb

  • Newbie
  • *
  • Karma: +0/-0
  • Posts: 2

I have two server for sending a smtp email . In first primary server I installed powerMTA and second server I did not install Powermta but I need to send email using second server with the ip address my config file below I  mentioned

<source 127.0.0.1>
          always-allow-relaying yes   # allow feeding from 127.0.0.1
        process-x-virtual-mta yes   # allow selection of a virtual MTA
        max-message-size 0          # 0 implies no cap, in bytes
        smtp-service yes            # allow SMTP service
        allow-mailmerge yes
</source>
 
<source 216.xxx.xxx.226>           # phplist or oempro installed
    always-allow-relaying yes 
    process-x-virtual-mta yes 
    max-message-size 0       
    smtp-service yes       
    hide-message-source true
    remove-header Received
</source>
 

 
<source 104.xxx.xxx.18>
    always-allow-relaying yes 
    process-x-virtual-mta yes 
    max-message-size 0       
    smtp-service yes       
    hide-message-source true
    remove-header Received
</source>
 
<source 0/0>                    # matches all
    log-connections no
    log-commands    no          # WARNING: verbose!
    log-data        no          # WARNING: even more verbose!
    allow-unencrypted-plain-auth no
    default-virtual-mta mta-pool
    process-x-virtual-mta yes
    smtp-service yes
    always-allow-api-submission yes
</source>
 
<virtual-mta mta1>
    <domain *>
        max-cold-virtual-mta-msg 100/day
    </domain>
    smtp-source-host 216.xxx.xxx.226 server1.globalhands.online       # MPTA installed
</virtual-mta>
 


<virtual-mta mta6>
    <domain *>
        max-cold-virtual-mta-msg 100/day
        dkim-sign yes
        #dkim-identity server2.globalhands.onlne
    </domain>
    smtp-source-host 104.xxx.xxx.18  server2.globalhands.online
</virtual-mta>


 

 
 
<virtual-mta-pool mta-pool>
    virtual-mta mta1
    virtual-mta mta6
</virtual-mta-pool>

#
# SMTP users (authenticated via SMTP AUTH)
#
#<smtp-user API>
#    password "changeme"
#</smtp-user>

#
# Settings per outgoing domain
#
#<domain discard.port25.com>
#    max-smtp-out    800
#    route           [192.168.0.1]:2525  # bypasses DNS resolution
#</domain>
#
#<domain test.port25.com>
#    max-smtp-out    1
#    log-connections yes
#    log-commands    yes     # WARNING: verbose!
#    log-resolution  no      # WARNING: verbose!
#    log-data        no      # WARNING: even more verbose!
#</domain>

#<domain {sparkpost}>
#    auth-username Your_API_key_goes_here    # generate under Account/API Keys
#</domain>

<domain *>
    max-smtp-out    200       # max. connections *per domain*
    bounce-after    4d12h    # 4 days, 12 hours
    retry-after     10m      # 10 minutes
</domain>

#
# Port used for HTTP management interface
#
http-mgmt-port 8080

#
# IP addresses allowed to access the HTTP management interface, one
# per line
#
http-access 127.0.0.1 monitor
http-access ::1 monitor
http-access 127.0.0.1 admin
http-access ::1 admin
http-access 113.193.xx.19 admin
http-access 0/0 admin
http-access 202.61.xxx.226 admin
http-access 0.0.0.0 monitor
http-access 202.61.xxx.226 monitor
http-access 0/0 monitor
http-access 104.192.xxx.18 admin
#http-access 10.1.0.10 none
#http-access 10.1.0/24 admin

#
# Whether to run the PowerMTA deamon as root
#
run-as-root no

#
# Logging file name
#
log-file /var/log/pmta/pmta.log   # logrotate is used for rotation

#
# Accounting file(s)
#
<acct-file /var/log/pmta/acct.csv>
#    move-to /opt/myapp/pmta-acct   # configure as fit for your application
    move-interval 5m
    max-size 50M
    delete-after 8d
</acct-file>

#
# Spool directories
#
<spool /var/spool/pmta>
    deliver-only no
</spool>

# EOF   


How to connect my second server Ip address in virtual mta.If I have added it  throwing a error "Local Ip address is not a valid" .Will please suggest me What I have did wrong on my configuration
Logged